Message Boards Message Boards

28 Replies
11 Total Likes
View groups...
Share this post:

Mac OS 10.9 (Mavericks) and Mathematica compatability

Posted 11 years ago
Anyone install OS 10.9 and test it with Mathematica yet? I have received numerous warnings from other software providers about the update not being compatible including RStudio, but Wolfram has not issued any updates or statements on the update so I am assuming there have been no reported issues. 
POSTED BY: Jon Rogers
28 Replies

I have now noticed that Time Machine activity seems to be correlated with the appearance of the "The notebook's file … has changed outside of Mathematica." message. I have seen several instances where this message dialog pops up whilst TM is doing its work, and I haven't noticed any instances of the message dialog when TM is NOT doing something. However, this message dialog appears only rarely (for me, that is) — i.e. it doesn't occur every time TM does a backup.

POSTED BY: Stephen Luttrell

Good observation. Thank you.

Not the case for my Mac, but it might have something to do with the problem. I will pass it on.

POSTED BY: Bruce Miller

re: "The notebook's file … has changed outside of Mathematica." message

It is erratic and it goes back to 10.8.
A few of us here encounter it annoyingly often. I have never encountered loss of data.

For now, the workaround is to turn off checking for notebook changes outside of Mathematica.
The steps are
- open the Option Inspector (under the Format menu),
- Set scope to Global preferences
- in the lower part of the window,
   * click Notebook Options
   * click File Options
   * click FileChangeProtection
   * click the box-with-triangle to the right of the option name
   * in the menu that opens, select None.
See the attached screen shot.

Option Inspector window

POSTED BY: Bruce Miller
Posted 10 years ago


I do NOT want to disable the warning, because what it warns of is real damage. A couple of times I thought nothing had changed and I saved my file, not realizing that the "closed" cells were not only closed, but erased. That meant a lot of lost work, and I had to recover older versions I had backed up. This kind of hazard does not seem up to the standards of either Apple or Wolfram, but is more reminiscent of using an early version of Word on a Windows machine where you develop a habit of hitting Command-S every few minutes as self-defense.

I am glad to hear others have experienced this problem, at least. How can we get it fixed, for real?


POSTED BY: John Gustafson

"How can we get it fixed, for real?" - Figure out what triggers it.

Developers and testers have spend two years on it and it is still elusive.

POSTED BY: Bruce Miller

I have experienced the same problem occasionally (MacBook Air, OS X 10.9.3, Mma 9.0.1) — maybe once a week for me — but I have never checked to see what has changed in the notebook. I always close without saving, and then revert to my previously saved version, which is OK for me as I am a habitual Command-S addict. I haven't yet noticed any particular conditions that correlate with the occurrence of this problem.

POSTED BY: Stephen Luttrell
Posted 10 years ago

I have a problem that does not seem to be posted previously, and seems to have started after I upgraded to Mavericks. I am working with a large notebook (about 150 pages, 35 MB) and about every half hour, I get a spontaneous "Why the Beep?" window that says "The notebook's file … has changed outside of Mathematica. The notebook has been renamed to Untitled-7. Mathematica has a complete record of changes made to the notebook, but might not be able to recover some of the unchanged cells. You can open the existing file again to reconcile any unsaved changes."

When I look for changes, Some of the cells that were in a closed state have been emptied. I open them and see Null. It's as if MacOS 10.9 is doing memory management improperly, and does not recognize some of Mathematica's memory state as being in use. Has anyone seen this type of error message, especially when working with large notebooks? It is not affected by other applications being open; it occurs even when Mathematica is the only application in use.

POSTED BY: John Gustafson
Posted 11 years ago
New Support Article to address basic Java-on-OSX issues:
POSTED BY: Peter Fleck
fyi,  Mr. BrockHaus's other thread was .

His situation is different from the Java problems discussed above.
Probably due to the OS upgrade but not MacOS 10.9-specific.
POSTED BY: Bruce Miller
Started separate discussion without knowing about this thread. It belongs here I believe:

Some days ago I've upgraded my IMac to Maverics. 30 minutes ago I've tried to launch my Mathematica 9 which welcomed me with Product Activation screen. Strange, the product was activated long time ago and was working flowlessly until the upgrade to Maverics. 
Online activation failed with the following error message (image): 

The manual activation attempt was similarly disappointing (image): 

Wolfram Research contacted (web page popped up after click on the link in the error message). Now looking at my mail and clicking refresh button now and then...
 Does it mean I need to roll back to previos OSX? 
Many thanks, Alexander 
Mr. Woldinga,

The striping is probably a different issue.

You said that restarting the computer fixed it.  Does it re-occur after a while, or is it permanently fixed?

If it re-occurs, I suggest holding down the SHIFT key as Mathematica starts up, to reset some
initialization files.  See
POSTED BY: Bruce Miller
Posted 11 years ago
Dear Mr. Miller,

Sorry for the late reply but thank you!
The problem did re-occur but after your suggestion holding down the SHIFT key Mathematica is working fine.
POSTED BY: Pieter Woldinga
Posted 11 years ago
Sometimes the Mathematica workspace windows does have "stripes" around it. The other programs running at the same time are doing fine. Restarting Mathematica won't help. I'll have to restart my MacBook Pro and then everything is ok.
Does anybody recognise this problem?

[PS My Mac was slow when running Mathematica but after installing Maverick (and the Java update) things got much better. Only thing that's slow now is when I start Safari when running Mathematica.]
POSTED BY: Pieter Woldinga
I have installed OS X 10.9 on both my computers without incident. For both computers, I was prompted to download and install JRE, as others have noted. Apple does not include this by default, and the download and installation is handled from Apple's servers. If Mathematica no longer uses Java, then perhaps there is a component in the installer that thinks it does.

It appears to be as speedy as ever.

2013 iMac 27 inch 32 Gbytes RAM, 3 TByte Fusion drive
2011 Macbook Air 11 inch, 4 Gbytes RAM, 128 GByte SSD
Mathematica makes use of Java for a number of things.  I do not have a list of elements that make use of it but, for example, DatabaseLink makes use of it as its communications link between Mathematica and the SQL databse.   Also, looking into the Mathematica distribution, RLink also makes use of Java as does WebServices and XMLSchema (and, of course, JLInk  ;-)  ). 
POSTED BY: David Reiss
Mathematica requires Java version 6 which is an earlier version than the current latest version.  For whatever reason, if you have Java 6 installed and then upgrade the Mac OS, the upgrade removes Java 6.  Hence the prompt to install it when first starting Mathematica after the OSX upgrade.
POSTED BY: David Reiss
Posted 11 years ago
I upgraded from Mountain Lion. Didn't have to do anything about Java. Mathematica runs, but has become very sluggish. Just as a number of other applications i run (Including VMware fusion, that normally ran Win7 and Ubuntu at the same time without problems).

Macbook Pro Retina, 2.6Ghz i7, 16gb ram, flash harddrive...
POSTED BY: Erik Sorensen
On my two macs, I was asked to update java se after the new OSX is installed. Not sure what would happen if you choose not to update. 

- Was your Mavericks update a complete reinstall on your system? I upgraded from Mountain Lion.
- Did you install Java before trying to run Mathematica the first time? Yes. I saw the java se prompt and update java first. Apple- java se 6 was installed in OSX 10.8 (Mountain lion)

- Did you try a preferences reset or a clean reinstall of Mathematica as described in the articles below help:
 No, I did not modify anything in Mathemtica after the OS upgrade and java se update. 
POSTED BY: Shenghui Yang
Posted 11 years ago
Since Mathematica 9, neither the front end nor the kernel launch Java automatically anymore, as our Java specialists have confirmed to me.

So if the reinstallation of Java on your machine fixed your previous inability to start Mathematica, is it possible that you are loading any specific packages or such at start-up, through according code in the init.m file?

Also, could you please describe what your original situation was:

- Was your Mavericks update a complete reinstall on your system?
- Did you install Java before trying to run Mathematica the first time?
- Did you try a preferences reset or a clean reinstall of Mathematica as described in the articles below help:  + a subsequent installation

It would help determining whether all of you have actually encountered the same or different situations.
Thank you.
POSTED BY: Peter Fleck
Posted 11 years ago
Here is my case:
- Was your Mavericks update a complete reinstall on your system?
 I upgraded from Mountain Lion.

- Did you install Java before trying to run Mathematica the first time?
 No. I was not prompted to install Java.
 Java 7 was installed before the upgrade but it seems that Java 7 was not working after the upgrade.

- Did you try a preferences reset or a clean reinstall of Mathematica as described in the articles below help: + a subsequent installation

The following is the message displayed when I tried to open Mathematica from a terminal:
LSOpenURLsWithRole() failed with error -10658 for the file /Applications/

Although I could not open Cyberduck and the same message was displayed,
the problem was also solved at the same time.

I hope the information helps.
POSTED BY: Nobuo Suematsu
Posted 11 years ago
Another case of Mathematica not launching after Mavericks upgrade:
Upgrade from Mountain Lion.I was not prompted to install Java.Preferences were reset with no improvementInstalling Java 6 and downgrading fixed the issue
POSTED BY: John Capehart
Posted 11 years ago
I encountered exactly the same problem.
It was solved by installing Java 6 issued by Apple (JavaForOSX2013-05)  and downgrading from Java 7 to Java 6 according to
POSTED BY: Nobuo Suematsu
Everything working fine: Macbook Pro Retina.
POSTED BY: Sander Huisman
I do not have issue to launch Mathematica 9 after this OS update. 
Just as @jari said, make sure you choose to update Java SE 6 at the end of the installation of OSX 10.9 
POSTED BY: Shenghui Yang
Posted 11 years ago
On the first start of Mathematica on OS X 10.9, it requested installing (new? specific?) version of Java, and I did it. After that, it just worked.
POSTED BY: Jari Kirma
Posted 11 years ago
On a hunch I closed everything, all windows, and then relaunched. A window was waiting for me, telling me that I need to install Java before I can run Mathematica. Incidentally same was true for my CrashPlan, part of what inspired me to check. So try closing (or minimizing) all of your windows, then you should see the Java installation dialog.

I'll know if that's all I needed in about an hour, the time it'll take to download Java.

Hope that helps! 
POSTED BY: Colin Chandler
I installed Mavericks today, and I am not able to open Mathematica.

I double-click the application icon, and the only thing that happens is that the icon expands out, as if I was opening any other application. No dock icon bounce or anything.
POSTED BY: Logan Howard
Posted 11 years ago
I also installed Mavericks and experience the same thing: launching Mathematica fails, it will only show the screen zoom as if it is launching an application but nothing past that.Very bad as I have deadlines. Had no choice, must start supporting this for clients immediately.
POSTED BY: Colin Chandler
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract