Message Boards Message Boards

8 Replies
13 Total Likes
View groups...
Share this post:

Bug at Wolfram|Alpha (Solve the indefinite integral, steps not available)

Posted 11 years ago
Hello. It's my first post here emoticon And this post is about the bug.
I sat and solved some tasks for my friend. I'm checking my answers only using Wolfram Mathematica and Wolfram|Alpha, but at that moment I saw very big answer for my task - "Solve the indefinite integral". Okay... May be it's true. Let's check the "step-by-step" solution. And Wolfram|Alpha said: "step-by-step solution unavailable". Why? Okay, how I can check answer? Okay, asked Wolfram|Alpha solve me the definite integral and only after that I checked my answer. I don't understand why "step-by-step solution unavailable" and why the answer is very hard for understanding at Wolfram|Alpha for this integral.

This post has links to the answer of Wolfram|Alpha and to my answer.
POSTED BY: Vitalii Barash
8 Replies
Posted 11 years ago
It is possible that the powerful, and thus extremely complicated, methods that Mathematica uses to solve some problems do not really have any simple easily understood steps that would be what a human would use to solve the problem.

To gain some confidence in the answer you might differentiate and simplify and see if you get the original back.

That gives me a little more confidence that it might be correct.

If you are looking for your simpler form then I am guessing that you are assuming that -1<x<1. If I let WolframAlpha know what you are assuming then I get

which is the same as yours. What would happen with your manual solution if x were not in that range you are assuming?

Just a helpful hint for the future, telling the Wolfram folks they have a bug, right or wrong, usually ticks them off.
Long long ago I tried to offer my own cash as prizes for anyone who could find a bug in my stuff. Management blocked that.
POSTED BY: Bill Simpson
Posted 11 years ago

I'll look into getting this fixed for you. In the mean time, you can see the steps by writing your integral as int x^2/((1-x^2)^(3/2)) dx, rather than int x^2/((1-x^2)^3)^(1/2) dx

The problem is (z^3)^(1/2) is not always equal to z^(3/2). To see a step-by-step solution why, check out

However, if we assume z >= 0, then (z^3)^(1/2) = z^(3/2).
POSTED BY: Greg Hurst
Posted 11 years ago
In the early days of Mathematica, we preferred the term "unexpected behaviour."
This leaves the door open.   ;-)
POSTED BY: David Keith
Posted 11 years ago
I remember a review, probably in the late '80s or very early '90s, maybe in American Math Monthly, where there was a sentence to the effect that putting Microsoft Windows and Mathematica together was trying to get the world's two least cooperative programs to play well together. Unfortunately I can't get an online article archive that goes back that far and I can't find the right words to help Google find it for me. The original sentence was much better than my fumbling attempt at recall. If anyone can find a reference to that sentence I'd love to see it again.

Every team has a culture and that has effects far beyond what you can imagine, so choose yours carefully.
POSTED BY: Bill Simpson
Why do you call it a bug?
POSTED BY: Sander Huisman
The bug... I mean the "step-by-step" solution is unavailable. It's a bug, because if the task solved, the system did some steps to solve it.
About form... Of course it's not the bug. Thanks, Bill Simpson. He wrote very good answer for me, I appreciate it.
POSTED BY: Vitalii Barash
I was able to get both Mathematica 7.0.1 and Wolfram Alpha to give the hand-calculated answer by introducing an assumption that 0 < x < 1. My instruction for both was Simplify[Integrate[ x^2/Sqrt[(1 - x^2)^3], x], 0 < x < 1] 
POSTED BY: Isaac Abraham
Lack of a feature is not a bug.
POSTED BY: Bruce Miller
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract