Message Boards Message Boards

GROUPS:

Installing the Wolfram Language and Mathematica on your Raspberry Pi

Posted 6 years ago
75044 Views
|
23 Replies
|
17 Total Likes
|
Mathematica and The Wolfram Language are now available from ours and the Raspberry Pi foundation's software repositories for the default Raspbian Linux distribution for the Pi. If you're running a Raspbian image provided by the Raspberry Pi foundation, you can now install the software with the following steps:
  1. Ensure that you have at least 600 megabytes of free storage on your Raspberry Pi's SD card. The package itself will take up 429 megabytes of disk space when installed.
  2. $ sudo apt-get update && sudo apt-get install wolfram-engine
  3. Agree to the licensing terms displayed (Use tab to move between fields in the license window. You will only need to do this once).
  4. Wait for the installation to complete. 
You should now find Mathematica and the Wolfram Language installed on the LXDE desktop under the Education menu and the Wolfram Language under the Programming 
menu.

In order to start the application from the Linux command line, type:
$ wolfram
To start Mathematica, type:
$ mathematica

If you have any questions about installing the application on your Raspberry Pi, feel free to ask! 
23 Replies
Hello Alex,
Thanks for this info. I am installing the Wolfram Language and Mathematica right now. I will share my experience with the community.
Will this work on a BeagleBone Black?  Will it work under Angstrom?

--Mark
Mark,

We have a prerelease program for the Wolfram Language (and Mathematica) on Linux-ARM (other than Raspberry Pi).
To apply for this program please send email to: prerelease@wolfram.com.
(I believe you have already done this and I have replied to your case privately).
Addme up please!
Please, add me to the pre release for ARM. I'm a user of the Beaglebone Black.
Posted 5 years ago

its is possible to install mathematica on beagle bone will be interested in experimenting with it ?

Arnoud's response here should be relevant to the Beagle Bone as well:

http://community.wolfram.com/groups/-/m/t/282758?p_p_auth=cCv0Ceaf

Please add me to this as well!

Please add me to this as well!

Is this offer still available? I sent an email to the said email but recieved no response...

Downloading the Java part took forever (about 3kB/s at times) and even generated errors.  However restarting the get-apt several times finally got it down.
Sorry to hear about the difficulties with the Java download. For the initial installation, you're downloading that file from the Raspberry Pi foundation and not from our servers, so there's little we can do about the bandwidth. We do host the Wolfram Engine package on our own servers, but the actual configuration for that repository gets added when you do the initial installation from the Raspberry Pi foundation. So, we'll do our best to make sure you get the package promptly when the first update goes out. 
Posted 6 years ago
The download/installation process on my RPi was very reasonable. I think the whole process took no more than 5 minutes.

I do have a few questions, though.

1. The installation put the app start shortcut for the Wolfram Engine in the Education and Programming folders. Should there be an app start shortcut for Mathematica as well? There is none for Mathematica on my RPi. Starting from the command line works fine, though.

2. When I open an existing notebook from the initial blank notebook, the window system positions the menu bar of the newly opened notebook off the top of my display in the upper left corner. This also happens when I open a notebook from the File Manager. I've done nothing to modify the configuration of how this should happen. I can't get my mouse on top of the menu bar to reposition the window. In order to get access to the menu bar, I have to use Alt-Space to open the window control drop-down that has the Move option. Has anyone else seen this?

Overall, I'm very impressed with how well Wolfram runs on the RPi.
Posted 6 years ago
David,

It looks like #1 was fixed with the new Raspbian update. I now have a shortcut for both Wolfram and Mathematica in the Education folder where before I only had Wolfram. 

I can't reproduce #2. What does happen, though, is that after I close the last notebook, there appears to be no way to open a new notebook because there's no menu bar. Unless I'm missing something obvious, that is. In Mathematica for Windows, there's a menu bar that remains after the last notebook is closed.

I, too, am really impressed by how well this works on the Raspberry Pi.

[Edit: And I now have been able to reproduce what you describe in #2, too.]
I down loaded Rasberrry Pildora OS.  It uses a RedHat Linux version .  What will be equivalent to get the Mathematica language installed using  yum?
Jose, 

We don't currently distribute the package as an RPM. It could hypothetically be installed with something like alien, but I'm not sure that it's distributed with Pidora. If you merely extract the contents of the debian package and place them into your filesystem, you could run the application directly provided it has libatlas3 available to it, but desktop integration like icons might not work as expected.

The easiest way to use Mathematica on the Raspberry Pi today is to use the Raspbian Linux distribution. We haven't gotten many requests for an RPM package, but it's something we're currently considering. 

Hey, trying to run 'sudo apt-get install wolfram-engine' I keep getting this: screenshot

I did run 'sudo apt-get update' and 'upgrade' previously. Any ideas what might cause the problem and how to get it to work?

I don't see anything unusual. It is just executing the upgrade installation. It takes a long time (About 30-40 minutes to completion)

I installed Wolfram and Mathematica on my Raspberry Pi Model B a month or 2 ago and only just now got around to trying it out, and I find that it won't do a lot of stuff the magazine articles say it should. (1). It will do stuff like x^y, and N[Pi,1000000]; but won't do (won't evaluate them) trig functions and logs. (2). I tried "Plot3D[Sin[x,y],{x,0,Pi},{y,0,Pi}]" and it replied with:- "Sin::argx : Sin called with 2 arguments; 1 argument is expected." (it repeated this 2 more times, followed by:- "General::stop : Further output of Sin::argx will be suppressed during this calculation.") (3). I also tried "Plot3D[Sin[x^3], {x,-2,2}]" and it just repeated it back to me - preceded by "Out[45]= ".

What's going on?

Sin requires one argument -- the angle. Perhaps you meant to plot Sin[x]Sin[y]? Plot3D requires two independent variables, since it plots a surface. Try this:

Plot3D[Sin[x] Sin[y], {x, -Pi, Pi}, {y, -Pi, Pi}]

Thanks for the quick reply - I copied that equation from a video demonstrating mathematica on a Raspberry Pi (RPi) - I was very careful in copying it exactly. However, when I tried your example, above, it worked! I solved my problem with trig and log functions by trial and error and found that, unlike Python, Mathematica requires a decimal point after a whole number to explicitly tell it to treat it as floating point. I'm happy now, thanks. :-)

But before you try to launch Mathematica, make sure the user you're going to be when you use it is a member of the 'video' group:

$ sudo usermod -a -G video xyz

does this for user 'xyz' (or you could just edit '/etc/group', if you're old-school)---and if you modified the current user, you'll then need to log out and back in.

The reason for this is that Mathematica needs access to video hardware devices, which are inaccessible unless you're a member of the 'video' group. If you aren't, the, uh, 'counterintuitive' (!) failure mode is that Mathematica presents a "Wolfram Product Activation" dialog and expects you to enter an activation key.

Posted 4 years ago

Thank you so much for posting the information about the user needing to be part of the 'video' group. My web searches were not getting me to answer until I finally stumbled onto your post. I'd done several things on my new RPi lately (one of them was deleting the default pi user account, of course), and couldn't figure out why Mathematica was suddenly asking for an Activation Code!

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract