Message Boards Message Boards

4 Replies
9 Total Likes
View groups...
Share this post:

Multiple "Raspberry Pi" remote kernels

I want to share my experience on getting rid of "Raspberry Pi" remote kernel multiplying. When using the Remote Development Pallete to configure the Pi Connection more then 1 times, you will notice that the kernels with the same names are multiplying.

Finding the place where I can edit kernels were rather challenging for the beginner. But I've managed to find the solution.
Go to Edit -> Preferences
Swith to Advanced tab
Click Open Option Inspector
Show Global Preferances by category
Expand Notebook Options and select Evaluation Options
You need to edit the EvaluatorNames parameter.
Click the button on right and do what you want with the kernels.
When you finish cleaning this menu, I also want to advice using Kernel Properties dialog to somehow run /usr/bin/wolfram as superuser.
Writing to GPIO is available only for him.

Hope to be helpful. Thanks.
POSTED BY: Himura Kazuto
4 Replies
I found the easy way. I don't know how can I have it misnoticed...
Evaluation -> Kernel Configuration Options
POSTED BY: Himura Kazuto
Nothing is so bad that it can't be made worse. I just went through this process without benefit of the advice in this conversation.

Instead, in my thrashing, trying things that might work, I set the default kernel to one of the RPi kernels. This turned out to be a terrible idea, because this disabled Mathematica. The RPi login dialog would come up whenever I tried to start it (I had never been able to figure out what the Remote Development Kit dialog was looking for) so the system was locked into a loop. The program managing the remote login dialog box couldn't be stopped by the Mac's Force Quit, the OK button, the cancel button, or the window close button. Mathematica itself could be stopped in the Mac Force Quit window. The problem infected all versions of Mathematica I had on my Mac, and it persisted through Trashing them all and reinstalling 9.0.1.

While I was casting around Google, looking for a way to avoid reformatting my hard drive, I had Mathematica idling in the background, blinking on and off in the Force Quit window with a "(not responding)" label attached. For reasons unknown, after a long time Mathematica's palettes finally appeared (pink) but the main menu was active. I was able to follow the instructions above, clean out the kernel list and reset the default kernel. A Christmas Miracle? Probably not, but pretty mysterious nonetheless.

So everything seems to be running fine. I'd still like to get the remote kernel running on the RPi, but I'm not eager to start messing with the RDK again.

Has anyone had success setting up the remote kernel from the Evaluation menu?

So far I've tried
 Evaluation > Kernel Configuration Options > Add
 Kernel name: RaspberryPi
 x Basic Options
    Launch on x Remote Machine
    Kernel program: wolfram
    Remote user: pi
    Remote host: < my RPi IP address from sudo ifconfig >
Evaluation > Kernel > Start Kernel > RaspberryPi

dialog box opens
key in pi password
Messages window: The kernel RaspberryPi failed to connect to the front end. (Error = MLECONNECT). You should try running the kernel connection outside the front end.

What next? I've been able to establish the link and run wolfram from the Mac Terminal via ssh, but not from a notebook. 

Any suggestions  would be welcome.

Fred Klingener 
POSTED BY: Fred Klingener
Posted 11 years ago

I get the same message regarding (Error = MLECONNECT) when I try to start a remote kernel on my RPi.

See this post: Error = MLECONNECT

I'm able to ssh into the RPi and run wolfram from a terminal, but not a remote kernel with a client FrontEnd.

I was hoping to get some help here, but no luck so far.
Posted 11 years ago
I wanted to follow up with some more information on the RDK connection issue. I moved my Mathematica Home Edition to a different PC on my LAN. After installing the RDK, I was able to successfully connect to my RPi. It's a mystery to me exactly why that is the case. The 2 PC's were very similar wrt hardware and installed software. The only thing that I can think that might affect the ability to connect is that on the original PC, I had installed Oracle's Virtual Box for running to virtual machines. Nothing like that is installed on the 2nd PC that connected to my RPi. I believe Virtual Box might do something with virtualized NIC's that may make that PC look like it has a different LAN IP address? I'm only guessing, though. I was able to connect to the RPI MathKernel through an ssh terminal on the original PC.
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract