Message Boards Message Boards

0
|
17735 Views
|
9 Replies
|
0 Total Likes
View groups...
Share
Share this post:

Is anyone else getting unexpected result from keybaord entry MMa V10?

Posted 10 years ago

If I use the keyboard entry for the nth root Ctrl[2] Ctrl[5], the Ctrl[2] is ok but at ctrl[5] it opens the CDF web deployment wizard. Choosing the entry from the assistant is fine. Paul.

POSTED BY: Paul Cleary
9 Replies
Posted 10 years ago

I have similar problems, Ctrl-C does open a TemplateNotebook for example. I'm on Windows 7 and use Mathematica 10.0.1. Which version do you use? Do you still have the problem or did you find out what the problem was?

POSTED BY: Albert Retey
Posted 10 years ago

I am using mma10.0.1 under windows 8.1. With the default nb style, Ctrl+2,Ctrl+5 gives me the root with two boxes to be filled in, which is what I think you wanted.

POSTED BY: Kevin McCann
Posted 10 years ago

Mathematica 10.0.1 Windows 7: Works the same as Kevin's (i.e., as expected). Albert: Ctrl-C is usually assigned to "Copy to the clipboard".

POSTED BY: Jim Baldwin

On my 10.0.1 on Windows 7, Ctrl[2] Ctrl[5] gives the root with two boxes to be filled in, as Kevin McCann got.

Control-C did nothing visible.

Three levels of quick checks:

  1. exit and restart Mathematica
  2. exit. Restart Mathematica while holding down the SHIFT key.
  3. exit. Restart Mathematica while holding down the SHIFT and CONTROL keys.

Conceivably the OS could be doing something odd. Have you rebooted recently?

Either of you using a non-English keyboard?

POSTED BY: Bruce Miller
Posted 10 years ago

Jim: I know what Ctrl-C is meant to do, I heavily rely on it every day and it is really annoying when that doesn't work, actually when it happens I have to restart Mathematica because without Ctrl-C, Ctrl-V and Ctrl-X working it is hardly possible to get any work done with it, at least for me..

Bruce: I don't think this is a configuration problem. The shortcuts do work alright within a new session, only after a while they become corrupted. And yes, I do reboot every day.

What I do use is a non-English Windows and a non-English keyboard, but I usually set the keyboard layout to English when I use Mathematica. My current suspicion is that this switching of keyboard language causes the problems. As long as I don't do that the keyboard shortcuts seem to work, but if I switch between the English and German keyboard layouts at some point the shortcuts get corrupted and the only way to get them working again is to restart Mathematica (no need to avoid the initialization). It still is only a suspicion but the switch of keyboard language seems to at least trigger that problem more frequently. I have now also seen states where only some of the shortcuts are corrupted but others work. And it is always the TemplateNotebook which opens instead of what the keyboard shortcut really was meant to do. Interestingly there seems to be no dedictated shortuct for opening a TemplateNotebook, but that's probably irrelevant.

POSTED BY: Albert Retey
Posted 10 years ago

Sorry, Albert. I misinterpreted your statement that "Ctrl-C does open a TemplateNotebook" as something you expected rather than something you thought was wrong. (Had I thought a bit more I should have figured that out. The "Publish" key is the one that causes me the most trouble.)

POSTED BY: Jim Baldwin
Posted 10 years ago

In case anyone is interested or is seeing the same problem: I have reported the behavior as described above to the technical support and have received an answer which confirms that the problem is triggered by switching the keyboard layout. The problem has been reported by others, is known to the developers and will hopefully be fixed in a future version. For the moment the solution is to not switch the keyboard layout during Mathematica sessions...

POSTED BY: Albert Retey
Posted 10 years ago

This seems to be fixed in version 10.0.2, at least I haven't seen it happen since I'm using that version anymore...

POSTED BY: Albert Retey
Posted 10 years ago

My issues seem to have been cleared up in 10.0.2.

POSTED BY: Kevin McCann
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract