Message Boards Message Boards

10 Replies
1 Total Likes
View groups...
Share this post:

Can anyone else verify that this font warning is a bug in 10.0.1?

Posted 10 years ago

This looks like a simple bug to me. M10.0.1, MacOS 10.9.5 Macbook Pro

f = Cos[x]
Plot[f, {x, -1, 1}, PlotLabel -> f]

Returns a pink graphic and throws a warning: "specified setting for FontSize cannot be used"

POSTED BY: W. Craig Carter
10 Replies

Found it.

This was in my old Library/.../Kernel/init.m

SetOptions[Plot,PlotStyle-> {Thick}, BaseStyle-> Medium]

Removing BaseStyle-> Medium appears to fix the problem.

POSTED BY: W. Craig Carter

Your code works fine in Mathematica 10.0.1, Windows 7. Seems to be a system specific bug...

POSTED BY: Bianca Eifert

For me is OK

POSTED BY: rafael ibanez

Thanks Bianca and Rafael,

Hmmm, strange...

The pink graphic and warning do not appear for me in M9.

I am not seeing anything in my init.m(s) that is obviously linked to an Option for Plot.

POSTED BY: W. Craig Carter

Tried the code on both my macs, running OS X 10.9.5. One of them is a Retina MacBook Pro. No errors at all.

For both these systems, I essentially threw out all the old Mathematica cruft -- I had stuff in the base directories from version 6. I did this during the beta tests to get rid of problems that while not exactly the same of this, were in the same general area -- basically just weirdness that could not be accounted for anywhere else.

My suggestion would be to make a copy of your base directories, do a clean install or just restart Mathematica, which will rebuild the defaults, and then add back in the files and folders you need from the backup.

The mechanism that Mathematica uses to store add-ons, options, etc., makes it easy to accumulate stuff. I did not investigate the problems I had, other than making them go away. Since I did that, there is only the 'normal' weirdness. ;-)


It could be a glitch in one of the Cache files that is starting part of the graphics system in an odd state. These can be reset by holding down just the SHIFT key as Mathematica launches.

If that does not help, does it happen in a new notebook? It could be something in the graphic from many tries ago that was copied over into the new graphics as they were made. My usual suggestion for this sort of warning is to delete the output cell and re-run the input.

POSTED BY: Bruce Miller

Thanks, George's approach worked, but now have a bit of work to do as I reconstruct some things I had.

Bruce, after copying the previous contents back into Library/Mathematica, I tried your approach two different ways. I tried the shift-launch, but that didn't eliminate the problem. I also tried removing Library/FrontEnd/10.0 Caches/ and that didn't work either. I also tried the delete-output reevaluate and that didn't solve it either.

I have a working solution, but the puzzle remains for another day.

Thanks, Craig

POSTED BY: W. Craig Carter


I'm running the same system as you Craig. Just typing your code into a new .NB worked fine. Pls see attached. No warning messages.



POSTED BY: David Mackay

Good that you found this. I didn't have the patience to go through 10 years of stuff that accumulated. I generally don't edit my init.m file, but some of the packages probably did. (When I saw my problems, I had not loaded anything, but there appears to be a mechanism that loads some stuff automatically and silently.)

The question is why this caused a problem now, as well as the similar problems I saw during the beta. I did file a bug report during the beta test.


Running the same Mma version and OS X version on a Mac mini without seeing this problem

POSTED BY: Mike Honeychurch
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract