Message Boards Message Boards

5 Replies
0 Total Likes
View groups...
Share this post:

Workspace Issue in WB 3.0

Posted 10 years ago

I recently installed WB 3.0 with Mathematica 10.0.1 on a Windows 8.1 64 bit machine. All seemed to work fine until I got an error indicating that the workspace I was trying to use could not be created or was in use (I first created \WolframWorkspaces\Base as given in TestProject online Tutorial). However, upon trying to create my own project, which went well I received a similar message that \WolframWorkspaces\Base was in use or unavailble so I created a new Workspace (\Wolfram\Workspaces\Base2)). This worked fine for a while, but then I got the same message and can not get access to my project files (in base2) since WB does not start but repeatedly generates the same error and thus is unable to bring up my projects.

I tried to create yet another Workspace (base3) to bootstrap WB into starting, which it does, and then use the Change Workspace option under file selecting the Base2 file containing my project, but this again blocked WB from restarting/refreshing itself.

I then went to the Windows Task Manager and killed all WB and Mathematica processes, as well as resorted to rebooting, but it seems as if there is a ghost Eclipse session still running somewhere on my machine blocking WB from using the Workspace containing my projects as the behavior will not correct itself, essentially rendering WB inoperable.

Has anyone else encountered this problem, have any idea of what is going on, or have a solution to this issue?

POSTED BY: Stuart Poss
5 Replies

I don't believe that Workbench 3.0 has been released. Are you a beta tester?

POSTED BY: David Reiss
Posted 10 years ago

Evidently, although perhaps not the best one as I am a novice to WB. As I have Premier Help Service, Wolfram was kind enough to provide a copy to use since WB 2.0 at least sometimes doesn't work with Mathematica 10.0 (at least not on my machine).

In reading online about issues associated with Eclipse sessions this seems to be an Eclipse workspace issue in that the locking files are not being properly unlocked and relocked or are otherwise somehow corrupted in the .metadata directory(ies). Unfortunately, suggestions there concerning deleting the lock file or starting the WB as admistrator do not seem to work (or at least those I have tried so far).

POSTED BY: Stuart Poss

The "Workbench 3" being talked about is a special-case, limited-release, pre-prerelease version that fixes a specific, serious problem connecting Mathematica 10 and Workbench 2.

If your Workbench mostly works with your Mathematica, this "Workbench 3" is not relevant for you.

POSTED BY: Bruce Miller
Posted 10 years ago

I was able to find a workaround by opening a new Workspace and then importing my project from the seemingly locked/corrupted base2 workspace. Not exactly a solution to the problem, but this did bring back WB 3.0 functionality and allow me to retrieve my project files.

POSTED BY: Stuart Poss

I wish I could provide some insight as to why this is happening -- unless Workbench was still running or did not exit cleanly? -- but I believe that you'll find that you have a file \WolframWorkspaces\Base\.metadata\.lock (and similar for the other workspaces that you can no longer access). With all copies of Workbench exited, delete that lock file and I expect that you'll be able to access that workspace again.

POSTED BY: Jeremy Michelson
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract