Message Boards Message Boards

GROUPS:

On Raspberry Pi 2, how do I get beyond the 'Product Activation' dialog?

Posted 7 years ago
23494 Views
|
16 Replies
|
13 Total Likes
|

Raspberry Pi 2, Jan 2015 Raspbian image. Launching Mathematica results in a 'Wolfram Product Activation' dialog and I'm asked for an Activation Key. What do I enter at this point so that I can click 'Activate'?

16 Replies
Posted 9 months ago

OK, to solve my own question: turns out only /dev/fb0 is (under Kali) owned by root:video while /dev/vchiq is owned root:root. Further, /dev/vchiq is NOT group read/writable.

Changing ownership from root:root to root:video and adding rw permissions for group to /dev/vchiq "solves" the issue, i.e. it allows Mathematica to work. While that's good, there are two things that are NOT good: a) the failure mode is absolutely horrid. b) what are the security implications of allowing regular users read write access to low level hardware? To make such permissions a requirement for Mathematica is, shall we say it politely, questionable.

Posted 9 months ago

Great, so I'm not completely alone....

I have the same symptoms: Mathematica/wolfram work for root user, but not for anyone else. Unfortunately the adding to the video group doesn't help, but also, I'm running Kali, rather than Raspian

Any ideas on how to debug this? Potentially this would require entries to the policy kit database somewhere below /etc/polkit-1/localauthority/... ???

The problem still exists as of 12.1.1:

➜  ~ wolfram
Mathematica 12.1.1 Kernel for Linux ARM (32-bit)
Copyright 1988-2020 Wolfram Research, Inc.

Mathematica 12.1.1 Kernel cannot find a valid password.

For automatic Web Activation enter your activation key
(enter return to skip Web Activation): 

You will need to get a password from your
license certificate or from Wolfram Research
(http://register.wolfram.com).
Machine name:   raspi2
MathID: 4703-79205-43531

You will need a valid activation key and password in order
to proceed. Go to http://user.wolfram.com to
register your activation key and obtain the password.

Enter your Activation key [format xxxx-xxxx-xxxxxx]: 

Enter your password: 

The password you entered is not valid.
Please press Enter to quit.

Adding the user to the video group fixed it for me. I figure adding full command output as above may help others (like a future me, once I've forgotten this) find this thread.

Edited to add: To fix the problem for the current user (regardless of that user's name), you can use:

sudo usermod -a -G video $(whoami)

Posted 7 years ago

I am new to Linux and Raspberry Pi (and need to stop saying that).

This worked for me. Just following the insructions worked.

Thank you Arnoud.

It is just a matter of finding the right expert at the right time.

peter mason

To add a user that can run the Wolfram Language:

pi@test-pi ~ $ sudo adduser pi2
Adding user pi2' ...
Adding new grouppi2' (1004) ...
Adding new user pi2' (1001) with grouppi2' ...
Creating home directory /home/pi2' ...
Copying files from/etc/skel' ...
[...]

Add it to the 'video' group (required as part of a number of checks that the Wolfram Language is running on a Raspberry Pi):



pi@test-pi ~ $ sudo usermod -a -G video pi2

Switch to 'pi2' account, and run the wolfram engine:

pi@test-pi ~ $ su - pi2
pi2@test-pi ~ $ wolfram
Wolfram Language (Raspberry Pi Pilot Release)
Copyright 1988-2015 Wolfram Research
Information & help: wolfram.com/raspi

In[1]:=

Ha! Excellent. Thanks.

I agree it is a counterintuitive way to fail. The appropriate developers have been made aware of this issue.

OK, so, if Mathematica can't access /dev/fb0 and/or /dev/vchiq, it reports this as a problem with licence activation. Forgive me if I seem crashingly naive, but this makes no sense at all!

Mathematica on 2nd Pi2 fixed the same way. We can but hope there are enough good keywords in this thread to bring other sufferers to this solution. I'd still quite like to know why, though.

Thanks again, Ilian!

Mathematica needs appropriate permissions to talk to the GPU hardware, and the 'video' group can access the corresponding device in /dev.

Posted 7 years ago

yup, adding the user to the video group did the trick for me as well. Thanks!

The user wasn't a member of the 'video' group, but it is now, and now Mathematica works. Thanks! So... What was going on there, then? There appears to be nothing on the entire RPi filesystem with that GID, as far as I can tell.

What user are you running Mathematica as? Is that user a member of the 'video' group?

sudo usermod -a -G video myuser

should do the trick.

Aha! It works for 'root'. Permissions problem somewhere, then. Investigation continues...

I've tried uninstall and reinstall, unsuccessfully. I found file '/opt/Wolfram/WolframEngine/10.0/Configuration/Licensing/mathpass' which contains what looks like an activation key, and entered that, but it appears to have expired. How is anyone using Mathematica on Raspberry Pi if no licensing and activation information is available?

Posted 7 years ago

I'm having the same problem.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract