Message Boards Message Boards

Plot3D Freezes Frontend

Posted 10 years ago

In MMA v10, when I evaluate more than one Plot3D command, the frontend freezes. After about 10 seconds, the "Disable Dynamic Evaluation" dialog pops up. The frontend remains locked up after clicking either button. I must use the Win 8.1 task manager to kill MMA. I've included a screen image of the notebook and the dialog. The freeze occurs upon evaluating the 2nd Plot3D command. Obviously, I'm not explicitly evaluating any Dynamic commands. I'm running with a fresh session and the default MMA configuration (eg, I've not made any changes to the default init.m files, etc). The same notebook appears to run fine in MMA v9.01.

Can anyone explain what the "Disable Dynamic Evaluation" dialog means and why it might pop up in this situation? Is it related to locking up the frontend? I'm at a loss about what is going on.

Plot3D Issue

16 Replies
Posted 10 years ago

In order to be more clear, I'm going to repost a couple of things I mentioned above:

I'm running with a fresh session and the default MMA configuration (eg, I've not made any changes to the default init.m files, etc). The same notebook appears to run fine in MMA v9.01.

  1. Can anyone explain what the "Disable Dynamic Evaluation" dialog means and why it might pop up in this situation?
  2. Is it related to locking up the frontend?

I did some troubleshooting by starting Win 8.1 in Safe Mode. I found that the notebook above runs without causing the frontend to lock up. I assume this means that there is a conflict with MMA V10 and some other software/driver on my PC. I have no idea how to determine the specific conflict. However, I believe that the dynamic evaluation dialog gives a hint about the underlying conflict. I asking if anyone can explain why the "Disable Dynamic Evaluation" dialog would be appearing following a simple sequence Plot3D commands?


I am using OSX and cannot reproduce the problem. It appears that there is dynamic content which runs into problems.

It appears that several "dynamic" items that are started automatically. This is a wild guess but you might want to try to get rid of as many as possible. You might for example want to temporarily disable the suggestions bar and the autocompletion:

You can also disable the dynamic highlighting in that same preferences menu. You might also want to change the dynamic updating and DynamicEvaluationTimeout in the option inspector. The more of the "intrinsic" dynamical content you switch off for this test the better. Perhaps that helps to narrow down what the problem is.



POSTED BY: Marco Thiel

If you haven't already tried completely removing the $UserBaseDirectory and $BaseDirectory and then restarting Mathematica, please try that. After removing these two folders, Mathematica will ask you to enter your activation key again. I understand that you haven't edited the init.m files, but there's been a number of occasions for myself where doing this has fixed some unknown configuration issue that I didn't think I could possibly could have. It is definitely worth trying even if you haven't edited anything in those directories.

  1. The dialog appears when something in the front end involving dynamic appears to be not updating. This can happen with large output or if there's some kind of issue. Plot3D is an example of a dynamic expression since it can be rotated. Basically any interactive output is dynamic. If you decide to disable dynamic updating, dynamic things such as Plot3D's output will generally show up as grey boxes.

  2. Yes it is very much related.

This is the first time I've seen this issue, so it's new to me. If you are still seeing this problem, please contact Wolfram Technical Support ( I suggest contacting them by email, since this will probably take a bit of investigative work to figure out and reproduce. When contacting them, let them know

  • Your activation key ($ActivationKey)
  • The issue appears despite removing the $UserBaseDirectory and $BaseDirectory or have already done a "clean start" of Mathematica
  • The issue appears despite disabling autocomplete and the suggestions bar per
  • Attach to the email a Mathematica notebook containing the output of the command SystemInformation[]. This will give them more information about your system such as what drivers are being used and the specifics of the OS.
POSTED BY: Sean Clarke
Posted 10 years ago

I've tried everything suggested. Unfortunately, the problem persists.

I even went through the process of reinstalling a fresh Win 8.1 and then MMA V10 (nothing else), but the problem persists. The only difference being the "Disable Dynamic Evaluation" dialog does not pop up anymore.

I did find out that the frontend does not lock up indefinitely. It will eventually come back (haven't timed it... it is many, many minutes). As soon as I interact with the plot, it locks up again. As you suggested, Sean, it is the interaction with the plot that is locking up the frontend.


Doesn't happen on my computer.

POSTED BY: Frank Kampas

No issues on my system either. OS X 10.9.4, Mathematica 10.0.

Sean's suggestion to pack up lots of information on the problem plus what you tried and to email it to is still a good one.

POSTED BY: Bruce Miller
Posted 10 years ago

At this point, I am disappointed in the lack of response I've received from I've contacted them 3 times now. I included the notebook, SystemInformation[], and DxDiag output files. I've only received an initial computer generated response. I appreciate the response from those that posted here on the Wolfram Community. However, it seems that Wolfram support is unconcerned. This is the 1st time in years that I've felt my Premier Service subscription is not a good value. My issue may be isolated, but it is real and it is somewhat similar to other issues I've seen posted here (eg, the "slow startup times...") and Stackexchange.

To reiterate what I mentioned in posts above:

  1. The issue does NOT occur when running in Win 8.1 Safe Mode.
  2. The issue does NOT occur in version 9 (on the exact same PC).
  3. The issue still occurs after a clean install of Win 8.1 and clean install of v10.0.

I think those 3 pieces of information, taken together, point to a change in v10.0.


I tried reproducing your problem on a computer running windows 8.1 and was not able to.
I have seen the error message you described, when I was beta testing version 10 and mistyped a command in the help menu. That problem seems to have been fixed in the release version.

One (difficult) way to attack the problem would be to have the windows process monitor running when you cause the problem to occur.

It's difficult because you get a description of everything the computer is doing at the time.

POSTED BY: Frank Kampas

As you said in an earlier post, the problem is probably due to some other program that's also running. You could use Task Manager to shut down other programs to try to see which one is causing the problem. Also, you could see if you're running out of memory when the problem occurs.

POSTED BY: Frank Kampas
Posted 10 years ago

Thanks to all that responded. I have a positive outcome to report.

Later this afternoon, I received a response from support. I happen to have multiple input devices (all USB) attached to my PC. The developers suggested that I remove all input devices except for a generic mouse and keyboard. After restarting with just those 2 devices, Plot3D/Graphics3D worked as expected... no frontend lockups.

Following that test, I began to shut down and reconnect my input devices one by one, testing Plot3D/Graphics3D after connecting each device. Plot3D/Graphics3D worked as expected after each step. So, now I have all my original devices connected and version 10.0 frontend is running Plot3D/Graphics3D flawlessly.

I'm not sure what the underlying problem was, but I suspect that it has to do with how version 10.0 interfaces with some USB input devices and how some devices maintain/present their state (even through a restart). Something certainly must have changed from version 9 to version 10. I'm guessing that removing/reconnecting the devices was adequate to put the devices into a state that version 10.0 expected to handle. Unfortunately, I don't have any way of knowing which devices may have caused version 10.0 to have an issue since there was no longer an issue as I reconnect my devices. Unless a specific device can be isolated as being troublesome, the recommendation would be to remove all input devices and then reconnect.

I don't understand why reinstalling Win 8.1 didn't correct the issue. I don't recall if I shut down the PC during this process.

I can provide a list of the input devices on my PC:

  • Steelseries MERC Programmable keyboard
  • Razer Hex Naga Programmable mouse
  • Wacom Intuos 3 Pen Tablet
  • 3DConnexion Spacenavigator
  • Logitech Extreme 3D Pro Joystick

Thanks to WRI support for responding and suggesting this procedure. It did occur to me to consider disconnecting devices. I had disconnected the Pen Tablet and Spacenavigator prior to hearing from support. However, that had no effect so I didn't even think of disconnecting my mouse/keyboard/joystick.

Hopefully, this information will be helpful in resolving the problem for future releases and/or for other users.

Posted 10 years ago

Another update to this thread.

The lockup problem reoccurred today. After more troubleshooting, I've determined that the lockup is occurring with the Logitech Extreme 3D Pro joystick connected. I'm not sure what sequence of events triggers the issue. The issue seemed fixed 2 days ago when I disconnected and reconnected all of my input devices.

At least I know that I can disconnect it whenever I'm using Mathematica. I will report this new information to support.



We received this hardware today and are able to reproduce the lockup you describe and are investigating the issue. There is no workaround at this point (other than disconnecting this hardware).

POSTED BY: Arnoud Buzing

I can't reproduce this on windows 7, version 10.0. No freezing or any other issues. The message you show should not come up, since you are not using any Dynamic. You might want to make sure you start fresh session and clear everything up and try again if you have not already done so.

enter image description here

POSTED BY: Nasser M. Abbasi


Do you also happen to have a wireless mouse and keyboard, like others who have reported slowness in startup? (I like to eliminate this as a possibilty; I am not able to reproduce your issue (also running Windows 8.1)).

POSTED BY: Arnoud Buzing
Posted 10 years ago


Thank you so much for the feedback. Hopefully, WRI will be able to come up with a resolution to the issue in a future release.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract